Lexus CT200h Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey I have a Ct200h produced in 2014 and new on this forum. Now I came back to my car and the entertainment system does not work anymore. The cd comes in of out of the radio, the mouse centers when turning on en off the car but no sound and a black screen. The fuses are good. What could this be?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Saw your thread, but my problem looks a bit different. I don't have a back up cam, but the mouse works and centered. After some diagnostics using some Lexus dealer steps and Techstream, I found out that it must be the radio itself. Send it away for reperations and they said two parts where broken in it. At the moment i'm already waiting 3/4 weeks because there is a long delivery time on the parts. When I know more I will update it.
 

·
Registered
2012 Premium with Nav
Joined
·
44 Posts
Saw your thread, but my problem looks a bit different. I don't have a back up cam, but the mouse works and centered. After some diagnostics using some Lexus dealer steps and Techstream, I found out that it must be the radio itself. Send it away for reperations and they said two parts where broken in it. At the moment i'm already waiting 3/4 weeks because there is a long delivery time on the parts. When I know more I will update it.
Hmm interesting. My year's radio may be different, I can't remember if the change was in 2014 or after 2014. On my year there is a metal box that mounts above the head unit, I believe that's what controls the back up cam / gps. Also note, my mouse centers it just doesn't do anything on the screen.

Next I remove my radio I will try out the back up cam and see if it works and get back to you. May not be for a few weeks.
 

·
Registered
Joined
·
8 Posts
just saw this post. having a similar issue. My car has been sitting in the garage for 5 weeks and when i started, no screen and or CD player/NAV. Backup camera works just fine.
what diagnostic steps have you tried ? could you pls share? i need to get my info system working asap (wife is bugging me, its her car).
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
Oke, so after a long time here I am again. The radio is broken and deemed unfixable by different companies. After contacting Lexus about the problem they first wanted to let the car diagnosed by a ´recognised dealer'. After bringing it there they had the same conclusion. Lexus contacted me again and let me know they wont be doing any waranty repairs or pay a part for this common problem. They told me however they could order a new one for 9000 euro. Well I just nicely told them the this will be my last Lexus. No service at all and no help. Car is from 2015 and with only a broken radio it is deemed total loss. In my opnion Lexus may be one of the worst brands I have ever owned after owning two of them with lots of problems. Another example is that my lx470 had a broken seat occupancy detector which was replaced. No problem there you would think. Well... the software from the old one needs to be transfered to the new one but that was corrupted. Lexus told us that they didn´t got the software from their own product, so it was unfixable. A LX470 (Land Cruiser) is made for 25 years and the safety system is deemed unfixable after only 15 years? So eventually I fixed that one my self for 0 euro. With this I warn everyone to stay away from Lexus, there service is the worst and parts are way to expensive.
 
1 - 7 of 7 Posts
Top