Lexus CT200h Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
New problems (Heater, coolant temp warning, yakima rack)

Greetings Forum, I've been here multiple times over the past few months (since buying my 2011 CT200h - 175k mi), but finally decided to join after coming across a few new quirks/problem that I've discovered in my new-old car.

Here's what I've encountered so far:

1.) Plastidip Nightmare - I spent probably 8 hours removing several thick layers of years-old baked-on plastidip from the rims which took about half a big bottle of goo-gone and whole pack of plastic razors, which liquified the dip and made it a tar-like, soupy mess, but finally got them back to normal.

2.) Then I noticed that the weatherstripping on one of the doors was sagging, so I removed it with no effort -- the adhesive inside was like a thick toothpaste-like consistency with no adhesion at all. 4/5 other door seals had the same problem, no bond. I don't know if that's common at all, but I cleaned out all the goop and reattached all the strips, which again took forever and was a mess, but now that's done.

3.) Then trying to put my Yakima rack on to this car I soon realized that the suggested installation measurements from Yakima were incorrect and had to do trial and error, then the old q-towers I'm using on the rack stripped during the re-installation process because they were old and design flawed, so I ordered new q-towers and now (while not perfect) that's done.

4.) Then I discovered, for whatever reason, I am getting a coolant temp. warning light that flashes from time to time even if I've only been driving for a few minutes. No associated problems that I know of except maybe...

5.) I am getting no heat whatsoever on the passenger side. I decided to look under the passenger dash and noticed a tar-like substance that seems to have melted and dripped down onto the carpet. I removed the panel under the passenger airbag and found a big wad of tar had settled onto the back corner of the panel closest to the engine/center console. I have no idea where it came from and don't know if it's related, but there it is...

Oh, and the center console latch sticks as many other people have experienced apparently.
Does anyone have any useful insight for what I'm dealing with??
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2 (Edited)
Update : I have done some more research into my main problems (i.e. coolant temperature warning light and passenger side heater not working) and I think I've found something.

It sounds like they could both be associated with a faulty thermostat. Can anyone who knows something about mechanics weigh in if this is possible? I am totally clueless with these things.

I didn't realize what a serious issue that could be, but the fact is that the warning never stays on and I have not actually had any issues manifest mechanically from what I've observed.
 
1 - 2 of 2 Posts
Top